Skip to main content

APT::Install-Recommends

I wonder why this parameter has been turned on. It confuses users and does things like:

# apt-get install mdadm
[....]
The following extra packages will be installed:
  citadel-common citadel-mta citadel-server db4.6-util libcitadel1 
  libcurl3 libglib2.0-0 libglib2.0-data libical0 libpcre3 libsieve2-1
  libssh2-1 libxml2 sgml-base shared-mime-info xml-core
[....]
0 upgraded, 17 newly installed, 0 to remove and 0 not upgraded.
I mean, what the hell, man? Why would I need citadel-server, which apparently is described as "a complete and feature-rich open source groupware platform" - huh? I only wanted to install mdadm! Fortunately one can set APT::Install-Recommends "false"; in apt.conf, and it'll just install with Depends: from now on.