Skip to content

debian/unstable and apache2.2

Well, I never thought I'd use this blog and I won't...usually, but somehow I think it might help others to get $TITLE running. Apache2.2 is out and v2.2.3 is in debian/unstable (at least i386) but php5 is not installable atm. What I did was basically:

 

$ apt-get install apache2-mpm-prefork apache2-prefork-dev \ php5-mysql php5
Only -prefork will work with mod_php5, FastCGI + php-cgi was not what I wanted. This will install apache2.2-common too, apache2-utils got installed too, the whole apache2 thingy seems to be in flux, but that's what unstable is for. Install php5 as well, only the apache2.2 module won't work. IIRC libapache2-mod-php5 is even a dependancy to php5 (next to the php5-cgi module), you might install with --force-all, I just won't work then, see the bugreport. As mentioned earlier, libapache2-mod-php5 won't install (and won't run, even when --force-all'ed), we're compiling it ourselves: - get php from http://TLD.php.net - install the missing -dev packages (configure will tell you...)

./configure --with-apxs2=/usr/bin/apxs2 \ --includedir=/usr/share/php --with-openssl --with-mysql --with-gd \ --with-ldap --with-zlib-dir=/usr/include/

make
Somehow I had to tell configure where zlib is, although /usr/include is a standard includepath, methinks. The --includedir parameter was important because I did not want to have a full blown php5 installation, I only wanted the libphp5.so for apache. Without --includedir php5 will use /usr/local/lib/php as include_path and some apps might break. Then, copy libs/libphp5.so to /usr/lib/apache2/modules/libphp5.so and apache2.2 should start nicely. mod_proxy_html was not installable either:

 

apxs2 -c -I/usr/include/libxml2 mod_proxy_html.c cp .libs/mod_proxy_html.so /usr/lib/apache2/modules/
That's how it worked for me, if it does not leave a comment or drop me an email. Have phun ;)