Skip to content

Internal Error, Could not perform immediate configuration (2) on mountall

# lsb_release -a 
Distributor ID: Ubuntu
Description:    Ubuntu karmic
Release:        9.10
Codename:    karmic

# apt-get update && apt-get -V dist-upgrade
[....]
Need to get 0B/197MB of archives.
After this operation, 239MB of additional disk space will be used.
Do you want to continue [Y/n]? 
E: Internal Error, Could not perform immediate configuration (2) on mountall
Huh? What happened here? I mean, I still had this mountall bug around, so it wouldn't surprise me if apt-get runs some hooks on mountall to make sure we're actually up & running. Let's "fix" mount for now:
# mountall 
swapon: /dev/mapper/swap: swapon failed: Device or resource busy
mountall: swapon /dev/mapper/swap [15521] terminated with status 255
mountall: Problem activating swap: /dev/mapper/swap

# grep swap /etc/fstab 
## /dev/mapper/swap swap       swap    pri=1        0       0

# mountall 
Now mountall returns properly, but apt-get dist-upgrade would still present the same error. Manually installing the package in question helped:
# dpkg --force-all -i /var/cache/apt/archives/mountall_2.10_amd64.deb
# apt-get -f install
# apt-get -V dist-upgrade

Trackbacks

No Trackbacks

Comments

Display comments as Linear | Threaded

Anonymous on :

i'd like to know that also, i'm having that trouble when i try to install kate editor does anyone know?

Christian on :

I wouldn't bother too much. mountall is some weird Ubuntu-voodo, replacing /etc/init.d/mountall.sh (from the initscripts package). Given the rate of changes in the mountall package, I'd say that its development is still in heavy flux, lots of bugs have been fixed lately. Unfortunately /sbin/mountall is a binary, so one could use --verbose or hammer with strace(1) against it to find out why it's complaining. Or: just use the source, Luke :-) Anyway, the workaround was working for me (dpkg -i), if it still doesn't work with the latest mountall version, I'd suggest to open a bug.

Lenin on :

While I did a: sudo apt-get install php5-curl I found the "Internal Error, Could not perform immediate configuration (2) on mountall" error. Found your article and typed: mountall and here is the mess that happened. I had to stop by pressing Ctrl+C process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library.process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library. process 5510: arguments to dbus_pending_call_set_notify() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 596. This is normally a bug in some application using the D-Bus library.^C family@family-desktop:~$ dpkg --force-all -i /var/cache/apt/archives/mountall_2.15_i386.deb dpkg: operation requires read/write access to dpkg status area family@family-desktop:~$ sudo dpkg --force-all -i /var/cache/apt/archives/mountall_2.15_i386.deb (Reading database ... 141046 files and directories currently installed.) Preparing to replace mountall 1.0 (using .../mountall_2.15_i386.deb) ... Unpacking replacement mountall ... dpkg: mountall: dependency problems, but configuring anyway as you requested: mountall depends on plymouth; however: Package plymouth is not installed. mountall depends on libnih-dbus1 (>= 1.0.0); however: Package libnih-dbus1 is not installed. mountall depends on libnih1 (>= 1.0.0); however: Package libnih1 is not installed. mountall depends on libplymouth2 (>= 0.8.1-3); however: Package libplymouth2 is not installed. mountall depends on libudev0 (>= 151-5); however: Version of libudev0 on system is 147~-6.1. Setting up mountall (2.15) ... Installing new version of config file /etc/init/mountall.conf ... Installing new version of config file /etc/init/mountall-net.conf ... Installing new version of config file /etc/init/mountall-reboot.conf ... Installing new version of config file /etc/init/mountall-shell.conf ... Configuration file `/etc/init/mounted-dev.conf', does not exist on system. Installing new config file as you requested. Configuration file `/etc/init/mounted-varrun.conf', does not exist on system. Installing new config file as you requested. Configuration file `/etc/init/mounted-tmp.conf', does not exist on system. Installing new config file as you requested. Processing triggers for ureadahead ... ureadahead will be reprofiled on next reboot Processing triggers for man-db ... family@family-desktop:~$ sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: upower libupower-glib1 Use 'apt-get autoremove' to remove them. The following extra packages will be installed: consolekit fontconfig-config gdm ifupdown indicator-applet indicator-applet-session initramfs-tools initramfs-tools-bin libatk1.0-0 libatk1.0-dev libc-bin libc-dev-bin libc6 libc6-dev libc6-i686 libdevkit-power-gobject1 libdrm-nouveau1 libdrm-radeon1 libfontconfig1 libfontconfig1-dev libglib2.0-0 libglib2.0-dev libindicator0 libnih-dbus1 libnih1 libplymouth2 libpopt0 libudev0 libupower-glib1 libxklavier16 plymouth plymouth-theme-ubuntu-text udev upower upstart ureadahead Suggested packages: uswsusp gok glibc-doc libglib2.0-doc python-subunit watershed Recommended packages: indicator-sound indicator-application indicator-me manpages-dev The following packages will be REMOVED: devicekit-power gnome-power-manager indicator-session ubuntu-desktop usplash usplash-theme-ubuntu The following NEW packages will be installed: initramfs-tools-bin libdrm-nouveau1 libindicator0 libnih-dbus1 libnih1 libplymouth2 libupower-glib1 libxklavier16 plymouth plymouth-theme-ubuntu-text upower The following packages will be upgraded: consolekit fontconfig-config gdm ifupdown indicator-applet indicator-applet-session initramfs-tools libatk1.0-0 libatk1.0-dev libc-bin libc-dev-bin libc6 libc6-dev libc6-i686 libdevkit-power-gobject1 libdrm-radeon1 libfontconfig1 libfontconfig1-dev libglib2.0-0 libglib2.0-dev libpopt0 libudev0 udev upstart ureadahead 25 upgraded, 11 newly installed, 6 to remove and 1411 not upgraded. Need to get 20.4kB/17.5MB of archives. After this operation, 7,426kB disk space will be freed. Do you want to continue [Y/n]? y Get:1 http://bd.archive.ubuntu.com lucid/main plymouth-theme-ubuntu-text 0.8.2-2ubuntu2 [20.4kB] Fetched 20.4kB in 4s (4,243B/s) Extracting templates from packages: 100% Preconfiguring packages ... (Reading database ... 141055 files and directories currently installed.) Removing ubuntu-desktop ... Removing gnome-power-manager ... Processing triggers for desktop-file-utils ... Processing triggers for hicolor-icon-theme ... Processing triggers for man-db ... (Reading database ... 140384 files and directories currently installed.) Preparing to replace libglib2.0-dev 2.22.3-0ubuntu1 (using .../libglib2.0-dev_2.24.1-0ubuntu1_i386.deb) ... Unpacking replacement libglib2.0-dev ... Preparing to replace libglib2.0-0 2.22.3-0ubuntu1 (using .../libglib2.0-0_2.24.1-0ubuntu1_i386.deb) ... Unpacking replacement libglib2.0-0 ... Processing triggers for man-db ... Setting up libglib2.0-0 (2.24.1-0ubuntu1) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place (Reading database ... 140396 files and directories currently installed.) Preparing to replace libc-bin 2.10.1-0ubuntu17 (using .../libc-bin_2.11.1-0ubuntu7.2_i386.deb) ... Unpacking replacement libc-bin ... Processing triggers for man-db ... Setting up libc-bin (2.11.1-0ubuntu7.2) ... Installing new version of config file /etc/gai.conf ... (Reading database ... 140396 files and directories currently installed.) Preparing to replace libc6 2.10.1-0ubuntu17 (using .../libc6_2.11.1-0ubuntu7.2_i386.deb) ... Checking for services that may need to be restarted... Checking init scripts... Unpacking replacement libc6 ... Setting up libc6 (2.11.1-0ubuntu7.2) ... Generating locales... en_AG.UTF-8... done en_AU.UTF-8... done en_BW.UTF-8... done en_CA.UTF-8... done en_DK.UTF-8... done en_GB.UTF-8... done en_HK.UTF-8... done en_IE.UTF-8... done en_IN.UTF-8... done en_NG.UTF-8... done en_NZ.UTF-8... done en_PH.UTF-8... done en_SG.UTF-8... done en_US.UTF-8... done en_ZA.UTF-8... done en_ZW.UTF-8... done Generation complete. Checking for services that may need to be restarted... Checking init scripts... atd start/running, process 1113 cron start/running, process 1112 Status of Common Unix Printing System: cupsd is running. * /usr/bin/mysqladmin Ver 8.42 Distrib 5.1.37, for debian-linux-gnu on i486 Copyright 2000-2008 MySQL AB, 2008 Sun Microsystems, Inc. This software comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to modify and redistribute it under the GPL license Server version 5.1.37-1ubuntu5.4 Protocol version 10 Connection Localhost via UNIX socket UNIX socket /var/run/mysqld/mysqld.sock Uptime: 1 hour 31 min 30 sec Threads: 1 Questions: 100 Slow queries: 0 Opens: 99 Flush tables: 1 Open tables: 23 Queries per second avg: 0.18 * postfix is running * could not access PID file for rsync gdm start/running, process 1105 Nothing to restart. Processing triggers for libc-bin ... ldconfig deferred processing now taking place (Reading database ... 140397 files and directories currently installed.) Preparing to replace libc6-i686 2.10.1-0ubuntu17 (using .../libc6-i686_2.11.1-0ubuntu7.2_i386.deb) ... Unpacking replacement libc6-i686 ... Selecting previously deselected package libnih1. Unpacking libnih1 (from .../libnih1_1.0.1-1_i386.deb) ... Setting up libnih1 (1.0.1-1) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place (Reading database ... 140406 files and directories currently installed.) Preparing to replace ureadahead 0.90.3-2 (using .../ureadahead_0.100.0-4.1.2_i386.deb) ... Unpacking replacement ureadahead ... Selecting previously deselected package libnih-dbus1. Unpacking libnih-dbus1 (from .../libnih-dbus1_1.0.1-1_i386.deb) ... Processing triggers for man-db ... Setting up libnih-dbus1 (1.0.1-1) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place (Reading database ... 140409 files and directories currently installed.) Preparing to replace libudev0 147~-6.1 (using .../libudev0_151-12_i386.deb) ... Unpacking replacement libudev0 ... Setting up libudev0 (151-12) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place (Reading database ... 140409 files and directories currently installed.) Preparing to replace ifupdown 0.6.8ubuntu21.3 (using .../ifupdown_0.6.8ubuntu29_i386.deb) ... Unpacking replacement ifupdown ... Processing triggers for man-db ... Setting up ifupdown (0.6.8ubuntu29) ... network-interface-security start/running (Reading database ... 140412 files and directories currently installed.) Preparing to replace upstart 0.6.3-11 (using .../upstart_0.6.5-7_i386.deb) ... Unpacking replacement upstart ... Processing triggers for man-db ... Setting up upstart (0.6.5-7) ... Installing new version of config file /etc/init/rc-sysinit.conf ... Installing new version of config file /etc/init/rc.conf ... (Reading database ... 140411 files and directories currently installed.) Preparing to replace libc6-dev 2.10.1-0ubuntu17 (using .../libc6-dev_2.11.1-0ubuntu7.2_i386.deb) ... Unpacking replacement libc6-dev ... Preparing to replace libc-dev-bin 2.10.1-0ubuntu17 (using .../libc-dev-bin_2.11.1-0ubuntu7.2_i386.deb) ... Unpacking replacement libc-dev-bin ... Preparing to replace libatk1.0-dev 1.28.0-0ubuntu1 (using .../libatk1.0-dev_1.30.0-0ubuntu2.1_i386.deb) ... Unpacking replacement libatk1.0-dev ... Preparing to replace libatk1.0-0 1.28.0-0ubuntu1 (using .../libatk1.0-0_1.30.0-0ubuntu2.1_i386.deb) ... Unpacking replacement libatk1.0-0 ... Preparing to replace libfontconfig1-dev 2.6.0-1ubuntu12 (using .../libfontconfig1-dev_2.8.0-2ubuntu1_i386.deb) ... Unpacking replacement libfontconfig1-dev ... dpkg: warning: unable to delete old directory '/usr/share/doc/libfontconfig1/fontconfig-devel': Directory not empty Preparing to replace libfontconfig1 2.6.0-1ubuntu12 (using .../libfontconfig1_2.8.0-2ubuntu1_i386.deb) ... Unpacking replacement libfontconfig1 ... Preparing to replace fontconfig-config 2.6.0-1ubuntu12 (using .../fontconfig-config_2.8.0-2ubuntu1_all.deb) ... Unpacking replacement fontconfig-config ... Selecting previously deselected package libindicator0. Unpacking libindicator0 (from .../libindicator0_0.3.8-0ubuntu1_i386.deb) ... Preparing to replace indicator-applet-session 0.2.0-0ubuntu2 (using .../indicator-applet-session_0.3.7-0ubuntu1_i386.deb) ... Unpacking replacement indicator-applet-session ... Preparing to replace indicator-applet 0.2.0-0ubuntu2 (using .../indicator-applet_0.3.7-0ubuntu1_i386.deb) ... Unpacking replacement indicator-applet ... Processing triggers for man-db ... Processing triggers for doc-base ... Processing 1 changed doc-base file(s)... Registering documents with scrollkeeper... Processing triggers for hicolor-icon-theme ... (Reading database ... 140439 files and directories currently installed.) Removing indicator-session ... Removing devicekit-power ... Removing usplash-theme-ubuntu ... update-initramfs: deferring update (trigger activated) Removing usplash ... update-initramfs: deferring update (trigger activated) Processing triggers for man-db ... Processing triggers for initramfs-tools ... update-initramfs: Generating /boot/initrd.img-2.6.31-22-generic Selecting previously deselected package initramfs-tools-bin. (Reading database ... 140323 files and directories currently installed.) Unpacking initramfs-tools-bin (from .../initramfs-tools-bin_0.92bubuntu78_i386.deb) ... Setting up initramfs-tools-bin (0.92bubuntu78) ... (Reading database ... 140328 files and directories currently installed.) Preparing to replace initramfs-tools 0.92bubuntu53 (using .../initramfs-tools_0.92bubuntu78_all.deb) ... Unpacking replacement initramfs-tools ... Processing triggers for man-db ... Setting up initramfs-tools (0.92bubuntu78) ... update-initramfs: deferring update (trigger activated) Processing triggers for initramfs-tools ... update-initramfs: Generating /boot/initrd.img-2.6.31-22-generic .: 4: Can't open /scripts/functions dpkg: considering deconfiguration of udev, which would be broken by installation of consolekit ... dpkg: yes, will deconfigure udev (broken by consolekit). (Reading database ... 140333 files and directories currently installed.) Preparing to replace consolekit 0.3.1-0ubuntu2 (using .../consolekit_0.4.1-3ubuntu1_i386.deb) ... De-configuring udev ... Unpacking replacement consolekit ... Preparing to replace udev 147~-6.1 (using .../archives/udev_151-12_i386.deb) ... Adding `local diversion of /sbin/udevadm to /sbin/udevadm.upgrade' Unpacking replacement udev ... Processing triggers for man-db ... Setting up udev (151-12) ... udev start/running, process 14784 Removing `local diversion of /sbin/udevadm to /sbin/udevadm.upgrade' update-initramfs: deferring update (trigger activated) Processing triggers for initramfs-tools ... update-initramfs: Generating /boot/initrd.img-2.6.31-22-generic .: 4: Can't open /scripts/functions Selecting previously deselected package libdrm-nouveau1. (Reading database ... 140348 files and directories currently installed.) Unpacking libdrm-nouveau1 (from .../libdrm-nouveau1_2.4.18-1ubuntu3_i386.deb) ... Setting up libdrm-nouveau1 (2.4.18-1ubuntu3) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place (Reading database ... 140354 files and directories currently installed.) Preparing to replace libdrm-radeon1 2.4.14-1ubuntu1 (using .../libdrm-radeon1_2.4.18-1ubuntu3_i386.deb) ... Unpacking replacement libdrm-radeon1 ... Setting up libdrm-radeon1 (2.4.18-1ubuntu3) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place Selecting previously deselected package libplymouth2. (Reading database ... 140354 files and directories currently installed.) Unpacking libplymouth2 (from .../libplymouth2_0.8.2-2ubuntu2_i386.deb) ... Setting up libplymouth2 (0.8.2-2ubuntu2) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place (Reading database ... 140367 files and directories currently installed.) Preparing to replace libdevkit-power-gobject1 011-1ubuntu2 (using .../libdevkit-power-gobject1_1%3a0.9.1-1_i386.deb) ... Unpacking replacement libdevkit-power-gobject1 ... Preparing to replace libpopt0 1.14-4 (using .../libpopt0_1.15-1_i386.deb) ... Unpacking replacement libpopt0 ... Selecting previously deselected package libxklavier16. Unpacking libxklavier16 (from .../libxklavier16_5.0-0ubuntu1_i386.deb) ... Preparing to replace gdm 2.28.1-0ubuntu2.2 (using .../gdm_2.30.2.is.2.30.0-0ubuntu3_i386.deb) ... Unpacking replacement gdm ... Selecting previously deselected package plymouth. Unpacking plymouth (from .../plymouth_0.8.2-2ubuntu2_i386.deb) ... Processing triggers for hicolor-icon-theme ... Processing triggers for desktop-file-utils ... Setting up plymouth (0.8.2-2ubuntu2) ... update-initramfs: deferring update (trigger activated) Processing triggers for initramfs-tools ... update-initramfs: Generating /boot/initrd.img-2.6.31-22-generic .: 4: Can't open /scripts/functions Selecting previously deselected package plymouth-theme-ubuntu-text. (Reading database ... 140413 files and directories currently installed.) Unpacking plymouth-theme-ubuntu-text (from .../plymouth-theme-ubuntu-text_0.8.2-2ubuntu2_i386.deb) ... Selecting previously deselected package libupower-glib1. Unpacking libupower-glib1 (from .../libupower-glib1_0.9.1-1_i386.deb) ... Selecting previously deselected package upower. Unpacking upower (from .../upower_0.9.1-1_i386.deb) ... Processing triggers for man-db ... Setting up libglib2.0-dev (2.24.1-0ubuntu1) ... Setting up libc6-i686 (2.11.1-0ubuntu7.2) ... Setting up ureadahead (0.100.0-4.1.2) ... Installing new version of config file /etc/init/ureadahead-other.conf ... Setting up libc-dev-bin (2.11.1-0ubuntu7.2) ... Setting up libc6-dev (2.11.1-0ubuntu7.2) ... Setting up libatk1.0-0 (1.30.0-0ubuntu2.1) ... Setting up libatk1.0-dev (1.30.0-0ubuntu2.1) ... Setting up fontconfig-config (2.8.0-2ubuntu1) ... Installing new version of config file /etc/fonts/fonts.conf ... Installing new version of config file /etc/fonts/conf.avail/25-unhint-nonlatin.conf ... Installing new version of config file /etc/fonts/conf.avail/30-metric-aliases.conf ... Installing new version of config file /etc/fonts/conf.avail/30-urw-aliases.conf ... Installing new version of config file /etc/fonts/conf.avail/45-latin.conf ... Installing new version of config file /etc/fonts/conf.avail/50-user.conf ... Installing new version of config file /etc/fonts/conf.avail/60-latin.conf ... Installing new version of config file /etc/fonts/conf.avail/65-fonts-persian.conf ... Installing new version of config file /etc/fonts/conf.avail/65-nonlatin.conf ... Installing new version of config file /etc/fonts/conf.avail/70-yes-bitmaps.conf ... Installing new version of config file /etc/fonts/conf.avail/90-synthetic.conf ... Setting up libfontconfig1 (2.8.0-2ubuntu1) ... Setting up libfontconfig1-dev (2.8.0-2ubuntu1) ... Setting up libindicator0 (0.3.8-0ubuntu1) ... Setting up indicator-applet (0.3.7-0ubuntu1) ... Setting up indicator-applet-session (0.3.7-0ubuntu1) ... Setting up consolekit (0.4.1-3ubuntu1) ... Installing new version of config file /etc/logrotate.d/consolekit ... Installing new version of config file /etc/X11/Xsession.d/90consolekit ... Setting up libdevkit-power-gobject1 (1:0.9.1-1) ... Setting up libpopt0 (1.15-1) ... Setting up libxklavier16 (5.0-0ubuntu1) ... Setting up gdm (2.30.2.is.2.30.0-0ubuntu3) ... Installing new version of config file /etc/dbus-1/system.d/gdm.conf ... Installing new version of config file /etc/gdm/gdm.schemas ... Installing new version of config file /etc/gdm/Xsession ... Installing new version of config file /etc/gdm/Init/Default ... Installing new version of config file /etc/gdm/PreSession/Default ... Installing new version of config file /etc/pam.d/gdm ... Installing new version of config file /etc/init/gdm.conf ... Adding group `nopasswdlogin' (GID 128) ... Done. Setting up plymouth-theme-ubuntu-text (0.8.2-2ubuntu2) ... update-alternatives: using /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth to provide /lib/plymouth/themes/text.plymouth (text.plymouth) in auto mode. update-initramfs: deferring update (trigger activated) Setting up libupower-glib1 (0.9.1-1) ... Setting up upower (0.9.1-1) ... Processing triggers for libc-bin ... ldconfig deferred processing now taking place Processing triggers for initramfs-tools ... update-initramfs: Generating /boot/initrd.img-2.6.31-22-generic .: 4: Can't open /scripts/functions family@family-desktop:~$

Christian on :

Wow, that's some messed up session over there (and sorry s9y did a crappy formatting job here). If you can reproduce this (on a pristine system, if possible), you probably should open (another) bug for this...

Lenin on :

I have solved the problem by following your post actually. I was in the middle of upgrading from Karmic to Lucid and as power is going in the middle I'm having breaks in that. But I had to install php5-curl in the middle as well, which generated this problem. Good that I got rid of it now :) ps. The formatting needs to be fixed :D

Add Comment

E-Mail addresses will not be displayed and will only be used for E-Mail notifications.
Form options

Submitted comments will be subject to moderation before being displayed.